Difference between revisions of "New Log"

From Win-Test Wiki
Jump to: navigation, search
(Step 2: Setup your log)
m (Opening your log automatically upon opening Win-Test: Show how to use Win-Test -n option on command line)
 
(15 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
Creating a new log in Win-Test is a two step process. Of course, this only needs to be done once, prior to the contest.
 
Creating a new log in Win-Test is a two step process. Of course, this only needs to be done once, prior to the contest.
  
== Step 1: Choosing a filename for your log ==  
+
== Step 1: Setup your log ==  
 
+
After starting Win-Test, click on the <tt>File | New...</tt> menu option or click the "New" toolbar icon. For more details, see [[Menu:File_new]]. The contest configuration screen is shown first:
Upon opening Win-Test, click on the <tt>File->New...</tt> menu option. Alternatively, with Win-Test in its default state without a log open you will have two toolbar icons available, too - new and open. Choose an appropriate filename for your log.
+
 
+
You can of course create the log within a new folder named after the particular contest in which you plan to participate.
+
 
+
Click the <tt>Open</tt> button once you have chosen an appropriate filename.
+
 
+
== Step 2: Setup your log ==
+
 
+
After choosing a filename for your log in step 1, you will be greeted with a window similar to the one below:
+
  
 
[[Image:Contest_configuration.png|center]]
 
[[Image:Contest_configuration.png|center]]
  
Hopefully this screen will be quite self-explanitory, but here's a brief summary of what the various entry fields indicate:
+
Hopefully this screen will be quite self-explanitory, but here's a brief summary of what the various entry fields indicate.  For more details, refer to [[Menu:File_new#Contest_Configuration]]:
 
* <code>Callsign</code> - enter the callsign which you plan to use during the contest  
 
* <code>Callsign</code> - enter the callsign which you plan to use during the contest  
* <code>Locator</code> - only required in contests which you give your locator as part of the exchange. This must be filled with a commplete locator (ex: JN18EV).
+
* <code>Locator</code> - must be filled with a complete locator (ex: CM97CF). To determine your locator, go to [http://f6fvy.free.fr/qthLocator/fullScreen.php http://f6fvy.free.fr/qthLocator/fullScreen.php], find your location on the interactive map, and click on it to display your grid square number.  This value is used to calculate beam headings and sunrise/sunset times for your QTH.
* <code>Exchange (zone, ...)</code> - If this field is editable, enter a CQ zone for the CQ WW contests, your year of first licence for the EU HF Championship, etc. It may be disabled for contests which require a serial number. And if the contest you take part in has a Domestic-side and a DX-side where a serial must be sent, enter "DX".
+
* <code>Exchange (zone, ...)</code> - If this field is editable, enter a CQ zone for the CQ WW contests, your year of first licence for the EU HF Championship, year of birth for the All Asian contest, your state for the NA Sprint, etc. It may be disabled for contests which require a serial number. If the contest has a Domestic-side and a DX-side where a serial must be sent, enter "DX".  Sets the '''<tt>$ZONE</tt>''', '''<tt>$STATE</tt>''', or '''<tt>$YEAR</tt>''' [[Message variables|message variables]] for CW messages, depending on the contest.
 +
* <code>DXCC Prefix</code> - your station's standard country prefix, from <tt>[[Other Files | cty.dat]]</tt>
 +
* <code>WAZ zone</code> - your station's CQ zone number
 +
* <code>ITU zone</code> - your station's ITU zone number
 +
* <code>State/Province/Other</code> - your station's U.S. state, Canadian province, or "DX".
 
* <code>Name</code> - the name which you want to be inserted into the final Cabrillo/ADIF log file
 
* <code>Name</code> - the name which you want to be inserted into the final Cabrillo/ADIF log file
 
* <code>Address</code> - the address which you want to be inserted into the final Cabrillo/ADIF log file
 
* <code>Address</code> - the address which you want to be inserted into the final Cabrillo/ADIF log file
* <code>Contest</code> - this is a drop-down list from which you choose the contest which you plan to partake in
+
* <code>Club</code> - the name of your radio club, for the Cabrillo log file (do not abbreviate)
 +
* <code>Load</code> - click one of these buttons to quickly load address and configuration information saved previously (one of five different configurations may be selected).  This avoids retyping everything when you create a new log.
 +
* <code>Save as</code> - click one of these buttons to save the current address and configuration information in one of the five preset buttons.  You will be prompted to name the button.
 +
* <code>Contest</code> - this is a drop-down list from which you choose the contest which you plan to partake in.  Check '''<tt>[This month only]</tt>''' to shorten this list considerably.  If you select DX Expedition, press the '''<tt>[Days...]</tt>''' button to set the span of the [[Menu:Windows#Statistics|Statistics Window]] from 1 to 15 days.
 
* <code>Category</code> - choose the appropriate category which you plan to enter in the contest
 
* <code>Category</code> - choose the appropriate category which you plan to enter in the contest
 +
* <code>Mode</code> - CW, PHONE, MIXED, RTTY, DIGITAL, or All modes?
 
* <code>Overlay</code> - if the particular contest supports a 'contest overlay' (e.g. CQ WPX), choose it from this drop-down list
 
* <code>Overlay</code> - if the particular contest supports a 'contest overlay' (e.g. CQ WPX), choose it from this drop-down list
* <code>Class</code> - the class you plan to enter (drop-down list)
+
* <code>Band plan</code> - click '''<tt>[Setup...]</tt>''' to set up frequency ranges, and Win-Test will automatically filter packet spots by frequency, showing only those spots that apply to your selected contest mode.  See [[Menu:Options#Bandplans...|Bandplans]] for more information.
* <code>Mode</code> - will you CW, SSB or MIXED?
+
* <code>Class</code> - the power class you plan to enter (drop-down list)
* <code>Operators</code> - this operator list will be inserted into the final Cabrillo log file. It must be a space-delimited list of operator callsign(s). You may also list the callsign of the host station by placing an "@" caracter in front of the callsign within the operator list.
+
* <code>Op. name</code> - the operator's name, sets the '''<tt>$MYNAME</tt>''' [[Message variables|message variable]]
* <code>Station name</code> - only important in a multi-op environment where each networked computer needs its own unique identifier
+
* <code>Operators</code> - this operator list will be inserted into the final Cabrillo log file. It must be a space-delimited list of operator callsign(s). You may also list the callsign of the host station by placing an "@" character in front of the callsign within the operator list.
 +
* <code>Station</code> - station name, only important in a multi-op environment where each networked computer needs its own unique identifier.  Check '''<tt>[Enable time distribution across the network]</tt>''' if you want this computer's clock to be the "master clock" for all networked computers.
  
Click OK to open your newly created log. Then, that's it! This only needs to be done once.  
+
Click one of the '''<tt>Save as</tt>''' buttons to save address and other information.  Click '''<tt>[OK]</tt>''' to open your newly created log. That's it! This only needs to be done once per contest log.
  
 
=== Editing the contest configuration ===  
 
=== Editing the contest configuration ===  
  
You can make changes in the above contest configuration dialog at any time by re-opening the log file. To do this, goto the <tt>File->Open</tt> menu option in Win-Test, and choose the appropriate log filename. Click <tt>Open</tt> and once again you will be greeted with the configuration dialog box. You can make any changes you like here and then click <tt>OK</tt>.
+
You can make changes in the above contest configuration dialog at any time by re-opening the log file. To do this, use the '''<tt>REOPEN</tt>''' or '''<tt>OPEN</tt>''' [[Text commands#List of Text Commands|text command]], or go to the <code>File | Open</code> menu option in Win-Test, and choose the appropriate log filename. Click <tt>Open</tt> and once again you will be greeted with the configuration dialog box. You can make any changes you like here and then click '''<tt>[OK]</tt>'''.
 +
 
 +
== Step 2: Choosing a file name for your log ==
 +
After selecting the contest type in step 1, you will see a window similar to the one below.
 +
 
 +
By default, Win-Test will generate a name for the log and place it in a new folder (or "sub-directory") named after the particular contest.
 +
 
 +
[[Image:FileNew.png|center|frame|Dialog allowing you to customize the name and location of your log file]]
  
 
== Opening your log automatically upon opening Win-Test ==  
 
== Opening your log automatically upon opening Win-Test ==  
  
If you wish, you can have Win-Test open the last opened log file upon start-up. This could be useful if you have to make a reboot (for whatever reason) during a contest and upon, for example, double-clicking the Win-Test icon on the desktop will open the last opened log file.  
+
If you wish, you can have Win-Test automatically open the last opened log file upon start-up. This is very convenient during a contest; all you have to do is double-click the Win-Test icon on the desktop and the log file will be opened.
 +
 
 +
To enable this feature, use the Win-Test menu to select <code>Options | Load contest at startup | Enabled</code>.
 +
 
 +
Close Win-Test and then restart to verify that it works.
 +
 
 +
After opening a log automatically, you can easily modify anything entered on the contest configuration screen by typing the [[Text commands#List of Text Commands|text command]] '''<tt>REOPEN</tt>'''.
  
To enable this feature, you will have to firstly open the log which you want to be opened automatically each time (as instructed above), and then goto the <code>Options->Load contest at startup->Enabled</code> menu option.
+
Note: by pressing and holding the '''[Ctrl]''' key during Win-Test startup, automatic file loading will be ignored.  You may also use the "-n" command line option to achieve the same affect:
  
Close Win-Test and then re-open to verify it works.
+
<code>wt -n</code>
  
 
== See Also ==
 
== See Also ==
  
* Merging/exporting log
+
* [[Menu:File_new]]
* ...
+
* [[Menu:File_new#Open]]
 +
* [[Menu:File_new#Export]]

Latest revision as of 00:51, 17 October 2011

Creating a new log in Win-Test is a two step process. Of course, this only needs to be done once, prior to the contest.

Step 1: Setup your log

After starting Win-Test, click on the File | New... menu option or click the "New" toolbar icon. For more details, see Menu:File_new. The contest configuration screen is shown first:

Contest configuration.png

Hopefully this screen will be quite self-explanitory, but here's a brief summary of what the various entry fields indicate. For more details, refer to Menu:File_new#Contest_Configuration:

  • Callsign - enter the callsign which you plan to use during the contest
  • Locator - must be filled with a complete locator (ex: CM97CF). To determine your locator, go to http://f6fvy.free.fr/qthLocator/fullScreen.php, find your location on the interactive map, and click on it to display your grid square number. This value is used to calculate beam headings and sunrise/sunset times for your QTH.
  • Exchange (zone, ...) - If this field is editable, enter a CQ zone for the CQ WW contests, your year of first licence for the EU HF Championship, year of birth for the All Asian contest, your state for the NA Sprint, etc. It may be disabled for contests which require a serial number. If the contest has a Domestic-side and a DX-side where a serial must be sent, enter "DX". Sets the $ZONE, $STATE, or $YEAR message variables for CW messages, depending on the contest.
  • DXCC Prefix - your station's standard country prefix, from cty.dat
  • WAZ zone - your station's CQ zone number
  • ITU zone - your station's ITU zone number
  • State/Province/Other - your station's U.S. state, Canadian province, or "DX".
  • Name - the name which you want to be inserted into the final Cabrillo/ADIF log file
  • Address - the address which you want to be inserted into the final Cabrillo/ADIF log file
  • Club - the name of your radio club, for the Cabrillo log file (do not abbreviate)
  • Load - click one of these buttons to quickly load address and configuration information saved previously (one of five different configurations may be selected). This avoids retyping everything when you create a new log.
  • Save as - click one of these buttons to save the current address and configuration information in one of the five preset buttons. You will be prompted to name the button.
  • Contest - this is a drop-down list from which you choose the contest which you plan to partake in. Check [This month only] to shorten this list considerably. If you select DX Expedition, press the [Days...] button to set the span of the Statistics Window from 1 to 15 days.
  • Category - choose the appropriate category which you plan to enter in the contest
  • Mode - CW, PHONE, MIXED, RTTY, DIGITAL, or All modes?
  • Overlay - if the particular contest supports a 'contest overlay' (e.g. CQ WPX), choose it from this drop-down list
  • Band plan - click [Setup...] to set up frequency ranges, and Win-Test will automatically filter packet spots by frequency, showing only those spots that apply to your selected contest mode. See Bandplans for more information.
  • Class - the power class you plan to enter (drop-down list)
  • Op. name - the operator's name, sets the $MYNAME message variable
  • Operators - this operator list will be inserted into the final Cabrillo log file. It must be a space-delimited list of operator callsign(s). You may also list the callsign of the host station by placing an "@" character in front of the callsign within the operator list.
  • Station - station name, only important in a multi-op environment where each networked computer needs its own unique identifier. Check [Enable time distribution across the network] if you want this computer's clock to be the "master clock" for all networked computers.

Click one of the Save as buttons to save address and other information. Click [OK] to open your newly created log. That's it! This only needs to be done once per contest log.

Editing the contest configuration

You can make changes in the above contest configuration dialog at any time by re-opening the log file. To do this, use the REOPEN or OPEN text command, or go to the File | Open menu option in Win-Test, and choose the appropriate log filename. Click Open and once again you will be greeted with the configuration dialog box. You can make any changes you like here and then click [OK].

Step 2: Choosing a file name for your log

After selecting the contest type in step 1, you will see a window similar to the one below.

By default, Win-Test will generate a name for the log and place it in a new folder (or "sub-directory") named after the particular contest.

Dialog allowing you to customize the name and location of your log file

Opening your log automatically upon opening Win-Test

If you wish, you can have Win-Test automatically open the last opened log file upon start-up. This is very convenient during a contest; all you have to do is double-click the Win-Test icon on the desktop and the log file will be opened.

To enable this feature, use the Win-Test menu to select Options | Load contest at startup | Enabled.

Close Win-Test and then restart to verify that it works.

After opening a log automatically, you can easily modify anything entered on the contest configuration screen by typing the text command REOPEN.

Note: by pressing and holding the [Ctrl] key during Win-Test startup, automatic file loading will be ignored. You may also use the "-n" command line option to achieve the same affect:

wt -n

See Also